IMA service failed to start with error 2147483649 and failed to load plug-ins

Citrix states in their article: CTX103253

CTX103253 - IMA service failed to start with error 2147483649 and failed to load plug-ins

This document was published at: http://support.citrix.com/kb/entry.jspa?externalID=CTX103253

Document ID: CTX103253, Created on: Jan 12, 2004, Updated: Feb 6, 2004

Products: Citrix MetaFrame XP 1.0 for Microsoft Windows 2000

Environment

MetaFrame XP 1.0

Symptom

The IMA Service failed to start and the following error message appeared:

“The IMA service returned a specific error 2147483649.”

The Event viewer displayed the following event IDs:

Event ID: 3601, “Failed to load plug-ins with error 80000001h.”
Event ID: 3609, “Failed to load initial plug-ins with error 80000001h.”
Event ID: 7024, “The Independent Management Architecture service terminated with service-specific error 2147483649.”

Cause

This occurs most often after an upgrade to a new service pack or after an attempt to restore a backup. The IMA Service cannot start due to a problem loading one of its subsystems.

The affected plug-in shows as the value for CurrentlyLoadingPlugin in the registry

Resolution

Edit the registry and check out these two value names shown below.

WARNING! This fix requires you to edit the registry. Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Ima/

Value Name: Directory: REG_SZ: C:\WINNT\System32\Citrix\IMA\SubSystems

Value Name: PluginDirectory: REG_SZ: C:\WINNT\System32\Citrix\IMA\SubSystems

Then verify that the location specified matches the exact location where all the plug-ins are on the disk

Additional Information

Review the following documents for other sources of information about this issue:

IMA failed to start with error code 2147483649
IMA service failed on startup. Service specific error 2147483649
Error: "Setup Could not Start the IMA Service"

Keywords: IMA_RESULT_FAILURE, 2147483649, plug-in, subsystem, 7024, 3601, 3609